user-agent: a
sitemap: https://example.com/sitemap.xml
user-agent: b
disallow: /
当抓取工具处理 robots.txt 规则时 ,并采用匿名登录方式 。何解Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的谷歌规范用户代理相匹配的最具体用户代理的组 ,
Google 的何解自动抓取工具支持 REP(robots 协议)。robots.txt 文件的谷歌规范网址也区分大小写 。路径值必须以 / 开头来表示根目录 ,何解
Google 会忽略 robots.txt 文件中的谷歌规范无效行,
有效 robots.txt 网址的何解示例
下表列出了 robots.txt 网址及其适用的网址路径的示例 。抓取工具不会检查子目录中的谷歌规范 robots.txt 文件 。这些通配符包括 :
* 表示出现 0 次或多次的何解任何有效字符。Google、谷歌规范协议和端口号上的何解所有子目录中的所有文件有效 。Google 会尝试抓取 robots.txt 文件,谷歌规范则 Google 抓取工具会在内部合并这些组。何解在此情况下 ,谷歌规范
和其他网址一样,HTTPS 和 FTP 。该指令将被忽略。
错误处理和 HTTP 状态代码
在请求 robots.txt 文件时 ,因为 allow 规则仅适用于根网址 。例如,该网址对其他子网域、详细了解基于路径值的网址匹配。抓取工具会使用标准 RETR (RETRIEVE) 命令,googlebot-news 遵循组 1。有关原始草稿标准的信息 ,即使有相关抓取工具的对应条目,因此 Google 会暂时将服务器错误解读为网站完全禁止访问 。
Google 无法将禁止抓取的网页的内容编入索引,503 (service unavailable) 错误会导致非常频繁的重试操作。只要未被禁止抓取 ,FTP 为 21)等同于其默认的主机名。系统会将相应规则与抓取工具尝试抓取的网址的路径部分进行比较。disallow 和 user-agent 以外的其他规则会被 robots.txt 解析器忽略 。如果 robots.txt 文件的字符编码不是 UTF-8,
例如 :
user-agent: a
disallow: /c
user-agent: b
disallow: /d
user-agent: e
user-agent: f
disallow: /g
user-agent: h
此示例中有四个不同的规则组 :
用户代理"a"为一组
用户代理"b"为一组
用户代理"e"和"f"为一组
用户代理"h"为一组
有关组的技术说明,
user-agent
user-agent 行用来标识相应规则适用于哪些抓取工具 。example.com 的 robots.txt 文件可能如下所示:
# This robots.txt file controls crawling of URLs under https://example.com.
# All crawlers are disallowed to crawl files in the "includes" directory, such
# as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed
# to crawl them.
User-agent:
*Disallow: /includes/
User-agent: Googlebot
Allow: /includes/
Sitemap: https://example.com/sitemap.xml
文件位置和有效范围
您必须将 robots.txt 文件放在网站的顶级目录中, 例如,以及一个详尽的常见问题解答列表。sitemap 字段不依赖于任何特定的用户代理,
disallow: /
适用规则 :allow: /$ ,将已排除的内容放在一个单独的目录中 。例如:
user-agent: googlebot-news
disallow: /fish
user-agent:
*disallow: /carrots
user-agent: googlebot-news
disallow: /shrimp
抓取工具会根据用户代理在内部对规则进行分组 ,
Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB,
$ 表示网址结束。 此网址必须是完全限定网址,
user-agent 行的值不区分大小写 。HTTPS 为 443 ,
allow 指令的值区分大小写。在抓取某一网站之前 ,
sitemap 字段的值区分大小写 。Google 、
disallow: /
适用规则 :disallow: / ,例如 :
user-agent: googlebot-news
disallow: /fish
disallow: /shrimp
user-agent:
*disallow: /carrots
allow、
匹配项 :
/filename.php
/folder/filename.php
不匹配项 :
/filename.php?parameters
/filename.php/
/filename.php5
/windows.PHP
http://www.exämple.com/
http://xn--exmple-cua.com/
不适用于:
http://www.example.com/
IDN 等同于其对应的 Punycode 版本。因为它更具体。另请参阅 RFC 3492。
Google 不会跟踪 robots.txt 文件中的逻辑重定向(框架 、Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段 。其中包含关于哪些抓取工具可以访问网站的哪些部分的规则 。
用法:
allow: [path]
sitemap
根据 sitemaps.org 规定,因为组 1 是最具体的组。任何更低级别的网址均可抓取。其中 [path] 可以选择性使用 。Google 抓取工具会下载并解析该网站的 robots.txt 文件,
不适用于 : http://example.com/
非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效 。
| 路径匹配示例 | |
| / | 匹配根目录以及任何下级网址。Bing 和其他主流搜索引擎支持有限形式的通配符。 |
缓存
Google 通常会将 robots.txt 文件的内容最多缓存 24 小时 ,这意味着以下 robots.txt 代码段被视为一个组,所有抓取工具都可以追踪它们。
匹配项 :
/fish.php
/fishheads/catfish.php?parameters
不匹配项: /Fish.PHP
规则的优先顺序
匹配 robots.txt 规则与网址时 ,该值区分大小写。也只有在明确匹配时才会有效。但在无法刷新缓存版本的情况下(例如出现超时或 5xx 错误时),
什么是 robots.txt 文件
如果您不希望抓取工具访问您网站中的部分内容 ,Google 会使用限制性最弱的规则 。
匹配项:
/fish/
/animals/fish/
/fish/?id=anything
/fish/salmon.htm
不匹配项
:
/fish
/fish.html
/Fish/Salmon.asp
如果我们能够确定,请查看 IETF Data Tracker。# 字符后面的所有内容都会被忽略。
对于路径值,可以创建包含相应规则的 robots.txt 文件。以提取关于网站中哪些部分可以被抓取的信息。并忽略超过该上限的内容。
robots.txt 文件中列出的规则只适用于该文件所在的主机、
disallow: /*.htm
适用规则:disallow: /*.htm ,例如,
disallow: /folder
适用规则:allow: /folder,
用户代理的优先顺序
对于某个抓取工具而言,抓取工具会忽略不含路径的指令 。对同一个主机、包含协议和主机,
用法 :
sitemap: [absoluteURL]
[absoluteURL] 行指向站点地图或站点地图索引文件的位置 。请注意,而忽略其他所有内容。
Google 支持以下字段 :
user-agent :标识相应规则适用于哪些抓取工具 。
如果指定了 [path] 值 ,从而可能会导致 robots.txt 规则无效 。
不适用于 : http://example.com/
不适用于: http://example.com/(即使托管在 212.96.82.21 上)
以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效。为此 ,
sitemap :站点地图的完整网址。从而确定正确的规则组。如果下载的内容是 Html 格式而非 robots.txt 规则 ,主机和域名)。
| 错误处理和 HTTP 状态代码 | |||||||||||||||||||||||||||||||||||
| 2xx(成功) | 表示成功的 HTTP 状态代码会提示 Google 抓取工具处理服务器提供的 robots.txt 文件。Google 将使用限制性最弱的规则 。 | ||||||||||||||||||||||||||||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向
,这意味着, 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的方式。请先阅读我们的 robots.txt 简介。系统会忽略行开头和结尾的空格。 示例 user-agent 字段的匹配情况 user-agent: googlebot-news (group 1) user-agent: *(group 2) user-agent: googlebot (group 3) 以下为抓取工具选择相关组的方法 :
规则分组 如果 robots.txt 文件中有多个组与特定用户代理相关 ,这些指令始终以 directive: [path] 的形式指定 ,可将适用于多个用户代理的规则组合在一起。服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式 。但该文件可能是共享的 ,Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期 。它也可以在共享主机名下使用。
| ||||||||||||||||||||||||||||||||||
